rvm 错误 Error running '__rvm_make install',

解决办法 rvm install 2.4.1 成功

下图是他的系统版本

ruby-2.3.1 - #removing src/ruby-2.3.1..
Searching for binary rubies, this might take some time.
No binary rubies available for: osx/10.12/x86_64/ruby-2.3.1.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for osx.
Certificates in '/usr/local/etc/openssl/cert.pem' are already up to date.
Requirements installation successful.
Installing Ruby from source to: /Users/liangkai/.rvm/rubies/ruby-2.3.1, this may take a while depending on your cpu(s)...
ruby-2.3.1 - #downloading ruby-2.3.1, this may take a while depending on your connection...
ruby-2.3.1 - #extracting ruby-2.3.1 to /Users/liangkai/.rvm/src/ruby-2.3.1....
ruby-2.3.1 - #configuring...........................................................
ruby-2.3.1 - #post-configuration.
ruby-2.3.1 - #compiling..............................................................
ruby-2.3.1 - #installing........
Error running '_rvm_make install',
showing last 15 lines of /Users/liangkai/.rvm/log/1491126703_ruby-2.3.1/install.log
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in
require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/security.rb:12:in <top (required)>'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in
require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/package.rb:44:in
<top (required)>'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core
ext/kernel_require.rb:55:in require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in
require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/installer.rb:10:in &lt;top (required)&gt;'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in
require'
from /Users/liangkai/.rvm/src/ruby-2.3.1/lib/rubygems/core_ext/kernel_require.rb:55:in require'
from ./tool/rbinstall.rb:657:in
<module:RbInstall>'
from ./tool/rbinstall.rb:585:in &lt;main&gt;'
make: *** [do-install-nodoc] Error 1
++ return 2
There has been an error while running make install. Halting the installation.
</pre></div>
</figure>

Comments

comments powered by Disqus